Amazon Music - Browse Issues
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted Sep 03, 2024 - 23:41 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 03, 2024 - 22:59 UTC
Investigating
We've identified a problem with Amazon Music on Sonos and are working with them on a fix. You may not be able to browse all Amazon Music menus in the Sonos app until it’s resolved.
Posted Sep 03, 2024 - 21:52 UTC
This incident affected: Amazon Music.