Cloud Cover Music - Adding Account Issue
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted Jul 01, 2023 - 16:09 UTC
Identified
We've identified a problem with Cloud Cover Music on Sonos and are working with them on a fix. You may not be able to sign in to your Cloud Cover Music account on Sonos until it's resolved.
Posted Jul 01, 2023 - 13:56 UTC