Amazon Music - Playback Issues
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted Nov 26, 2020 - 06:25 UTC
Investigating
We've identified a problem with Amazon Music on Sonos and are working with them on a fix. You may be unable to start playing music from Amazon Music until it’s resolved.
Posted Nov 25, 2020 - 18:27 UTC
This incident affected: Amazon Music.