Amazon Music - Browse Issues

Incident Report for Sonos

Resolved

This incident has been resolved.
Posted Dec 24, 2024 - 19:08 UTC

Identified

We've identified a problem with Amazon Music on Sonos and are working with them on a fix. You may not be able to browse Amazon Music menus in the Sonos app until it’s resolved.
Posted Dec 24, 2024 - 18:09 UTC
This incident affected: Amazon Music.