Nugs.net - Unable to add the service to Sonos
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted Nov 22, 2022 - 11:26 UTC
Investigating
We are currently investigating this issue.
Posted Nov 22, 2022 - 02:12 UTC
This incident affected: nugs.net.