I Love Music - Browse Issue
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted Mar 07, 2024 - 15:55 UTC
Identified
We've identified a problem with I Love Music on Sonos and are working with them on a fix. You may not be able to browse I Love Music menus in the Sonos app until it's resolved
Posted Mar 07, 2024 - 14:17 UTC
This incident affected: I Love Music.