myTuner Outage
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted Dec 18, 2019 - 21:16 UTC
Investigating
We are currently investigating this issue.
Posted Dec 18, 2019 - 18:49 UTC
This incident affected: myTuner Radio.