AccuRadio - Unable to browse Genres
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted Jul 27, 2022 - 18:31 UTC
Update
We are continuing to investigate this issue. As a workaround, please use the Search functionality to start playback.
Posted Jul 26, 2022 - 21:37 UTC
Investigating
We are currently investigating this issue.
Posted Jul 26, 2022 - 18:58 UTC
This incident affected: AccuRadio.