SiriusXM - Browse Failure  - Partial browse failure
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted May 21, 2020 - 17:09 UTC
Identified
Some SiriusXM accounts are unable to browse on Sonos. SiriusXM continues to work on a solution to this issue.
Posted May 17, 2020 - 21:07 UTC
Investigating
SiriusXM has identified the issue and is working on a resolution.
Posted May 17, 2020 - 18:15 UTC
This incident affected: Sirius XM.