Spotify Functionality Issue
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 12, 2019 - 05:02 PDT
Investigating
Posted 5 months ago. Mar 12, 2019 - 04:46 PDT
This incident affected: Spotify.