Fabel - Browse failure.
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted Jan 15, 2020 - 11:51 UTC
Identified
We’ve identified a problem with Fabel on Sonos and are working with them on a fix. You may be unable to start playing music from Fabel until it’s resolved.
Posted Jan 15, 2020 - 10:25 UTC
This incident affected: Fabel.