iHeartRadio - Browse Failure
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted Jan 10, 2020 - 18:50 UTC
Investigating
We've identified a problem with iHeartRadio on Sonos and are working with them on a fix. You may not be able to browse iHeartRadio in the Sonos app until it’s resolved.
Posted Jan 10, 2020 - 17:26 UTC
This incident affected: iHeartRadio.