Sonos Customer Care Phone Issues
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted Sep 14, 2019 - 00:09 UTC
Investigating
Some of our offices are currently experiencing Internet Service Outages, and it may take longer than an hour for us to take your call. If your question is not urgent, we recommend you ask the community or send us an email. You can also reach us on Twitter via @SonosSupport.
Posted Sep 13, 2019 - 23:37 UTC