Napster - Unable to add
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 21:44 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 21, 2022 - 19:20 UTC
This incident affected: Napster.