Stitcher Update
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted Mar 30, 2021 - 14:50 UTC
Monitoring
Stitcher's service will be undergoing maintenance from 9am to 10am Pacific. After this maintenance is complete, all Stitcher users will be required to reset their password with Stitcher and reauthorize the service on Sonos. If you run into any problems, please contact Stitcher customer support at https://www.stitcher.com/faqs
Posted Mar 24, 2021 - 14:46 UTC
This incident affected: Stitcher.