Major - Murfie - Adding Account Failure
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted about 2 months ago. Jul 01, 2019 - 19:39 PDT
Investigating
Murfie is experiencing a service interruption on Sonos. We are currently investigating this issue.
Posted about 2 months ago. Jun 29, 2019 - 18:20 PDT
This incident affected: Murfie.