My Cloud Home - Adding Account Failure
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted Jul 29, 2023 - 02:12 UTC
Investigating
We've identified a problem with My Cloud Home on Sonos and are working with them on a fix. You may not be able to sign in to your My Cloud Home account on Sonos until it’s resolved.
Posted Jul 28, 2023 - 11:02 UTC