Primephonic - Playback issues
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted Feb 24, 2020 - 13:50 UTC
Identified
We've identified a problem with Primephonic on Sonos and are working with them on a fix. You may be unable to start playing music from Primephonic until it’s resolved.
Posted Feb 24, 2020 - 09:52 UTC
This incident affected: Primephonic.