Napster - Browse Failure - Full browse failure
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 13, 2019 - 14:47 PDT
Investigating
Napster is currently investigating a service degradation.
Posted 5 months ago. Mar 13, 2019 - 09:10 PDT
This incident affected: Napster.