Mixcloud - Playback issues
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted Nov 18, 2020 - 09:01 UTC
Identified
We've identified a problem with Mixcloud on Sonos. Mixcloud are currently working on their infrastructure and have been experiencing issues. You may experience playback issues until it’s resolved.
Posted Nov 13, 2020 - 13:07 UTC
This incident affected: Mixcloud.