Apple Music - Partial Browse Issues

Incident Report for Sonos

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 20:34 UTC

Investigating

We've identified a problem with Apple Music on Sonos and are working with them on a fix. You may not see all results while browsing Apple Music in the Sonos app until this is resolved.
Posted Mar 18, 2025 - 19:32 UTC
This incident affected: Apple Music.