Planet Radio - Adding Account Issue
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted Mar 22, 2022 - 13:35 UTC
Identified
We've identified a problem with Planet Radio on Sonos and are working with them on a fix. You may not be able to sign in to your Planet Radio account on Sonos until it's resolved.
Posted Mar 21, 2022 - 15:44 UTC