Fit Radio Workout Music - Browse Issues

Incident Report for Sonos

Resolved

This incident has been resolved.
Posted Feb 21, 2025 - 01:10 UTC

Identified

We've identified a problem with Fit Radio Workout Music on Sonos and are working with them on a fix. You may not be able to browse Fit Radio Workout Music menus in the Sonos app until it’s resolved
Posted Feb 20, 2025 - 18:07 UTC
This incident affected: FIT Radio Workout Music.