Mixcloud - Full browse failure
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted Aug 26, 2020 - 13:10 UTC
Investigating
We've identified a problem with Mixcloud on Sonos and are working with them on a fix. You may not be able to browse Mixcloud menus in the Sonos app until it’s resolved.
Posted Aug 26, 2020 - 10:50 UTC
This incident affected: Mixcloud.