Mixcloud - Browse Issues
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted Dec 14, 2020 - 14:14 UTC
Identified
We've identified a problem with Mixcloud on Sonos and are working with them on a fix. You may not be able to browse Mixcloud menus in the Sonos app until it’s resolved.
Posted Dec 14, 2020 - 10:22 UTC
This incident affected: Mixcloud.