Major - Anghami - Browse Failure - Full browse failure and Unable to add account
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted 4 months ago. May 09, 2019 - 09:14 PDT
Investigating
Anghami is experiencing service issues on Sonos.
Posted 4 months ago. May 08, 2019 - 10:20 PDT