iHeart Radio - Browse and Adding Account Issues
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted Oct 22, 2024 - 16:57 UTC
Identified
We've identified a problem with iHeart Radio on Sonos and are working with them on a fix. You may not be able to sign in to your iHeart Radio account or Browse music on Sonos until it’s resolved.
Posted Oct 22, 2024 - 15:55 UTC
This incident affected: iHeartRadio.