Audible - Browse Issues
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted May 29, 2023 - 19:26 UTC
Identified
We've identified a problem with Audible on Sonos and are working with them on a fix. You may not be able to browse any Audible menus in the Sonos app until it’s resolved.
Posted May 29, 2023 - 18:16 UTC
This incident affected: Audible.