Saavn - Browse Issue
Incident Report for Sonos
Resolved
This incident has been resolved.
Posted Sep 12, 2022 - 20:01 UTC
Identified
We've identified a problem with Saavn on Sonos and are working with them on a fix. You may not be able to browse Saavn menus in the Sonos app until it's resolved
Posted Sep 09, 2022 - 10:09 UTC